Xcode5 运行IOS7以下的,如:IOS6模拟器

发布时间:2014-10-23 23:28:05
来源:分享查询网

Xcode 5默认自带SDK 7.0,升级Xcode 5后,Xcode.5就没了,这样我想编译SDK 6.x的程序就难办了(除非同时安装Xcode 4.x和Xcode 5.x两个版本Xcode)。其中我们知道xcode有个Base SDK。但是xcode5默认只自带SDK 7.0的。那么如何实现可选择老版本的呢(如SDK 6.x)。 这里给出如何把老版本的SDK加入到新的Xcode中的方法。其实很简单,就是将老版本的sdk拷贝过去。 打开老的Xcode安装路径(你可以去 Apple Dev Center 下载老版本的Xcode dmg包,解压出来对应的SDK包。):Applications/Xcode.app/Contents/Developer/Platforms /iPhoneOS.platform/Developer/SDKs .这个路径中安装了你当前Xcode的所有Base SDK(例如 “iPhoneOS6.1.sdk”),同样的你只需将这个sdk 备份一份拷贝到新的xcode相同目录下即可。安装完新版Xcode 5后同样将备份的sdk拷到对应路径: Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs下即可。重启你的Xcode,打开Project Targets -> Build Settings -> Base SDK,设置为对应的sdk即可(例如ios6) 这时候你可能会发现运行起来的模拟器还是ios7的,要想模拟器是ios6的,同样的只需要到路径/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs下将对应的simulator备份的新得xcode路径下即可。 哈哈  你也可以试试 把IOS7 弄到Xcode5以下的版本

返回顶部
查看电脑版