让ffmpeg0.5版本支持3gp格式

发布时间:2014-10-25 2:22:37
来源:分享查询网

 ffmpeg默认情况下是不支持3gp格式的,如果想它支持3gp格式需要在configure时使用--enable-libamr_nb和--enable-libamr_wb,而这两个参数需要libamrnb和libamrwb库的支持。我们先下载这两个库的源码wget http://ftp.penguin.cz/pub/users/utx/amr/amrnb-7.0.0.2.tar.bz2wget http://ftp.penguin.cz/pub/users/utx/amr/amrwb-7.0.0.3.tar.bz2   我觉得这两个包一般都找7.x版本就可以,没必要再用6.x版的了解压后分别./configure --prefix=/usr #这里必须指定到/usr目录,否则ffmpeg在./configure的时候会找不到相关的库文件makemake install 安装完毕后,进入ffmpeg-0.5目录./configure --enable-nonfree --enable-libamr_nb --enable-libamr_wb#这个版本必须要有--enable-nonfree才能支持后面的两个参数makemake install 如果在make的时候出现 undefined reference to `Encoder_Interface_Encode' 错误,则有可能是以前make的残余文件导致,可以在./configure之前先make distclean一下。 然后ffmpeg -i 03.rmvb -ar 8000 -ac 1  -s 352x288 -r 12 -b 200 -ab 12.2k 03.3gp就可以了,注意选择正确的长度、宽度、比特率等参数才能正确转换

返回顶部
查看电脑版